Proposal to Implement New Routing Protocol Solutions

1203 words (5 pages) Essay in Information Systems

08/02/20 Information Systems Reference this

Disclaimer: This work has been submitted by a student. This is not an example of the work produced by our Essay Writing Service. You can view samples of our professional work here.

Any opinions, findings, conclusions or recommendations expressed in this material are those of the authors and do not necessarily reflect the views of UK Essays.

Network Proposal

 This document is a proposal to implement new routing protocol solutions to an existing network. It is intended to provide the necessary details for the changes and how it will affect the network and its users. The proposed solutions listed below have been proven to be beneficial in a number of ways and meets industry standards. By implementing this proposal we would increase network stability, create a more scalable network, maximize bandwidth use and generate a more stable flow of network traffic.

Create a multiprotocol operational network using EIGRP, OSPF and RIPv2 protocol

 EIGRP (Enhanced Interior Gateway Routing Protocol) is a hybrid routing protocol meaning it has the features of both distance vector and link-state protocols. Since it has a full scope of the topology, EIGRP offers 100% loop free routing.  Classless routing is also achieved with EIGRP allowing support for VLSMs (Variable Length Subnet Mask) which creates more usable host.

 The main goal of routing protocols is learn routes. OSPF (Open Shortest Path First) protocols accomplishes this by learning about every router and subnet in the entire network (“IBM Knowledge Center,” n.d.). Route changes are transmitted to the whole autonomous system in the shortest time with OSPF’s fast convergence.

 RIPv2 (Routing Information Protocol version 2) is an improved version of RIPv1. Unlike EIGRP which is a hybrid protocol, RIPv2 is a distance vector routing protocol with a total hop count of 15. Anything beyond the hop count of 15 is considered an unreachable route.

EIGRP Configuration

RouterA(config)#router eigrp 100

RouterA(config-router)#network 192.168.1.0

RouterA(config-router)#network 192.168.1.1

RouterB(config)router eigrp 100

RouterB(config-router)#network 172.16.0.0

RouterB(config-router)#network 192.168.1.1

RIPv2 Configuration

RouterA(config)router rip

RouterA(config-router) # network 192.168.1.0

RouterA(config-router) # network 192.168.1.1

RouterA(config-router) # version 2

OSPF Configuration

A0(config)#router ospf 0

A0(config-router)#network 172.16.12.0 0.0.0.3 area 1

A0(config-router)#network 192.168.1.0 0.0.0.255 area 1

A1(config)#router ospf 1

A1(config-router)#network 172.16.12.0 0.0.0.3 area 1

A1(config-router)#network 192.168.1.0 0.0.0.255 area 1

A2(config)#router ospf 2

A2(config-router)#network 172.16.12.0 0.0.0.3 area 2

A2(config-router)#network 192.168.1.0 0.0.0.255 area 2

Implement a secure update of OSPF and EIGRP protocols

 It is possible for for malicious or incorrect information to be introduced into the routing table. In order to stop this from happening OSPF and EIGRP MD5 authentication can be implemented which authenticates routes and updates exchanged between routers.

Enabling OSPF MD5 Authentication:

RouterA(config)#interface fa0/0

RouterA(config-if)#ip ospf message-digest-key md5 top_secret

RouterA(config)#router ospf 100

RouterA(config-router)#area 0 authentication message-digest

Enabling EIGRP MD5 Authentication:

RouterA(config)#key chain cmit-451

RouterA(config-keychain)#key 1

RouterA(config-keychain)#key-string Terrence

RouterA(config)#int fa0/0

RouterA(config-if)#ip authentication mode eigrp 1 md5

RouterA(config-if)#ip authentication key-chain eigrp 1 cmit-451

Implement a virtual link in one segment of the network

 A virtual link is used in a situation where a routing device on the backbone is not physically connected to the backbone (“OSPF Virtual Link,” n.d.). If this is the case, a virtual link must be established between the backbone and the routing device.

Virtual Link Configuration

RouterA(config)#router ospf 1

RouterA(config-router)#area 2 vir

RouterA(config-router)#area 2 virtual link 192.168.0.3

Implement a redistribution system

Since there are two separate networks running different routing protocols the routes between the two must be redistributed in order for communication to continue. Route redistribution allows routers between the two networks to learn each others routing tables. This is accomplished by advertisement of all routes even static and directly connected. As with any multiprotocol network metrics must be defined for each protocol.

EIGRP to OSPF redistribution configuration:

Router(config)#router ospf 1

Router(config-router)#redistribute eigrp 1

Router(config-router)#redistribute eigrp 1 metric 1

Router(config-router)#redistribute eigrp 1 metric 10

 

Implement BGP connection to ISPs

Having access to multiple ISPs provides internet redundancy. With the implementation of BGP (Border Gateway Protocol), the network can be multihomed with two different ISPs (admin, 2018). As traffic flows each router stores the routes from their neighbor and later uses it to forward traffic. This means network traffic runs on the existing routers and has the ability to select the best path from multiple ISPs.

RouterA(config)#router bgp 89001

RouterA(config-router)#neighbor 192.168.68.2 remote-as 89001

RouterA(config-router)#neighbor 10.2.2.1 remote-as-89002

RouterB(config)#router bgp 89001

RouterB(config-router)#neighbor 192.168.68.2 remote-as 89001

Implement a solution which avoids your network becoming a transit hub for BGP external routes

 Although BGP has its benefits it does not not come without some possible downfalls as well. Implementing BGP there is a possibility that your autonomous system will become transit. If so, traffic will then bypass the autonomous system and possibly consume all the CPUs resources and  bandwidth.

 With the use of a filter-list with the AS PATH access, all advertised network traffic will be from prefixes from within your own AS.

Filter-list with AS PATH access-list

RouterA(config)#ip as-path access-list permit ^$

RouterA(config-router)neighbor 192.168.68.2  filter-list out

RouterA(config-router)neighbor 192.168.68.4  filter-list out

Get Help With Your Essay

If you need assistance with writing your essay, our professional essay writing service is here to help!

Find out more

Cite This Work

To export a reference to this article please select a referencing stye below:

Reference Copied to Clipboard.
Reference Copied to Clipboard.
Reference Copied to Clipboard.
Reference Copied to Clipboard.
Reference Copied to Clipboard.
Reference Copied to Clipboard.
Reference Copied to Clipboard.

Related Services

View all

DMCA / Removal Request

If you are the original writer of this essay and no longer wish to have the essay published on the UK Essays website then please:

McAfee SECURE sites help keep you safe from identity theft, credit card fraud, spyware, spam, viruses and online scams Prices from
£124

Undergraduate 2:2 • 1000 words • 7 day delivery

Order now

Delivered on-time or your money back

Rated 4.6 out of 5 by
Reviews.co.uk Logo (188 Reviews)