What Is Ether Channel Computer Science Essay

Published:

This essay has been submitted by a student. This is not an example of the work written by our professional essay writers.

What is Ether Channel. You might be thinking that ok, there is an Ethernet link that would be connected between a router or a switch and providing a channel for the communication or lets say data transmission. Well if yes, then, you are right. Amazed? But there is a something interesting that makes it a wide concept and more than just a communication channel. How? Without further ado let's start then.

Ether channel combines multiple individual links, providing a logical link. Simple right?

This logical link is able to provide up to 16Gbps of bandwidth (Known as Gigabit Ether Channel) or 1600Mbps of bandwidth (Known as Fast ether Channel) between two Cisco Catalyst Switches. But please note that the all of the interfaces taking part in creating an Ether Channel should be configured as of same speed and duplex along with the both ends configured as Layer 2 or Layer 3 interface.

Ok, now what happens if one of the links in the ether channel fails? Any guesses? Well, if any of the links fail on the ether channel, the traffic flows on the remaining links.

Now let's talk about the protocols that provide the link aggregation in this all setup. There are two of the protocols provided that is responsible for the formation of EtherChannel.

Port Aggregation Protocol (PAgP) - This is a Cisco proprietary protocol

Link Aggregation Protocol (LACP) - This is the IEEE standard

PagP is very interesting and honestly you are going to love it too. What it is doing is, PAgP packets are sent over the fast Ethernet links to negotiate the forming of a link (Fast Ether Channel Link). When our PAgP identifies matched Ethernet link, it creates a EtherChannel by grouping the links. EtherChannel is then added to the spanning tree as a single bridge port as we don't want to flood the network and want to use the EtherChannel efficiently.

PAgP has three modes of operation;

(i) Auto (ii) Desirable (iii) On

Mode - Auto: Places an interface into a passive negotiating state, in which the interface responds to PAgP packets it receives but does not start PAgP packet negotiation. This setting minimizes the transmission of PAgP packets and is the default.

Mode - Desirable: Places an interface into an active negotiating state, in which the interface starts negotiations with other interfaces by sending PAgP packets.

Mode - On: Forces the interface to channel without PAgP. With the on mode, a usable EtherChannel exists only when an interface group in the on mode is connected to another interface group in the on mode.

So much for PAgP for now. Let's check LACP and see what it can do.

LACP is part of an IEEE specification. It allows several physical ports to be combined together to form a single logical channel. LACP allows a switch to negotiate an automatic bundle by sending LACP packets to the peer. It performs a similar function as PAgP with Cisco EtherChannel. Because LACP is an IEEE standard, it can be used to facilitate EtherChannel in mixed-switch environments.

Just like PAgP, our LACP also comes with three modes of operation which are;

i) Auto (ii) Desirable (iii) On

Mode - Auto: he switch does not initiate the channel, but does understand incoming LACP packets. The peer (in active state) initiates negotiation (by sending out an LACP packet) which we receive and reply to, eventually forming the aggregation channel with the peer. This is similar to the auto mode in PAgP.

Mode - Desirable: We are willing to form an aggregate link, and initiate the negotiation. The link aggregate will be formed if the other end is running in LACP active or passive mode. This is similar to the desirable mode of PAgP.

Mode - On: The link aggregation is forced to be formed without any LACP negotiation .In other words, the switch will neither send the LACP packet nor process any incoming LACP packet. This is similar to the on state for PAgP.

Ok finally we are done with the theory. Now here comes the fun part. Yes you are right the configuration part and I love it as much as you do. Before the configuration, please note that we can configure EtherChannel as Layer2 and Layer3, So we will start with the configuration of Layer2 and then Layer3.

Layer2 EtherChannel Configuration

In this example we will configure Switch1 as in the active mode and switch2 in the passive mode while creating EtherChannel and for that we have to create a new VLAN e.g. VLAN-30 and the interfaces 0/1-3 on both of the switches are going to in this VLAN.

Switch(config)#hostname Switch1-Layer2-EtherChannel

Switch1-Layer2-EtherChannel(config)#vlan 30

Switch1-Layer2-EtherChannel(config-vlan)#name ETHER-CHANNEL

Switch1-Layer2-EtherChannel(config-vlan)#exit

Switch1-Layer2-EtherChannel(config)#inter rang fastEthernet 0/1-3

Switch1-Layer2-EtherChannel(config-if-range)#switchport mode access

Switch1-Layer2-EtherChannel(config-if-range)#switchport access vlan 30

Switch1-Layer2-EtherChannel(config-if-range)#channel-protocol lacp

Switch1-Layer2-EtherChannel(config-if-range)#channel-group 1 mode ?

active Enable LACP unconditionally

auto Enable PAgP only if a PAgP device is detected

desirable Enable PAgP unconditionally

on Enable Etherchannel only

passive Enable LACP only if a LACP device is detected

Switch1-Layer2-EtherChannel(config-if-range)#channel-group 1 mode active

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to up

This is all that we have to do on the Switch-1. Now let's move on to Switch-2 which is going to be in the 'Passive' mode for the channel-group.

Switch(config)#hostname Switch2-Layer2-EtherChannel

Switch2-Layer2-EtherChannel(config)#vlan 30

Switch2-Layer2-EtherChannel(config-vlan)#name ETHER-CHANNEL

Switch2-Layer2-EtherChannel(config-vlan)#exit

Switch2-Layer2-EtherChannel(config)#inter rang fastEthernet 0/1-3

Switch2-Layer2-EtherChannel(config-if-range)#switchport mode access

Switch2-Layer2-EtherChannel(config-if-range)#switchport access vlan 30

Switch2-Layer2-EtherChannel(config-if-range)#channel-protocol lacp

Switch2-Layer2-EtherChannel(config-if-range)#channel-group 1 mode ?

active Enable LACP unconditionally

auto Enable PAgP only if a PAgP device is detected

desirable Enable PAgP unconditionally

on Enable Etherchannel only

passive Enable LACP only if a LACP device is detected

Switch2-Layer2-EtherChannel(config-if-range)#channel-group 1 mode passive

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to up

Ok now we are done with the configuration of Layer2 Ether Channel.

Layer3 EtherChannel Configuration

In this case we will configure PAgP on Switch-1 with "Mode- Desirable" and on Switch-2 there is going to be "Mode- Auto". You might be thinking why this is happening? Why not configuring Auto-Auto or Desirable-Desirable? The answer is that, to configure link aggregation, Switch-1 and Switch-2 should be Desirable-Auto respectively. Now let's make the configurations:

Switch1-Layer3-ETHERCHANNEL# configure terminal

Switch1-Layer3-ETHERCHANNEL(config)# interface port-channel 1

Switch1-Layer3-ETHERCHANNEL(config-if)# no switchport

Switch1-Layer3-ETHERCHANNEL(config-if)# ip address 172.16.1.11 255.255.255.0

Switch1-Layer3-ETHERCHANNEL(config-if)# exit

Switch1-Layer3-ETHERCHANNEL(config)# interface range fa 0/1 -3

Switch1-Layer3-ETHERCHANNEL(config-if-range)# no switchport

Switch1-Layer3-ETHERCHANNEL(config-if-range)# no ip address

Switch1-Layer3-ETHERCHANNEL(config-if-range)# channel-group 1 mode desirable

Switch1-Layer3-ETHERCHANNEL(config-if-range)# end

Switch2-Layer3-ETHERCHANNEL# configure terminal

Switch2-Layer3-ETHERCHANNEL(config)# interface port-channel 1

Switch2-Layer3-ETHERCHANNEL(config-if)# no switchport

Switch2-Layer3-ETHERCHANNEL(config-if)# ip address 172.16.1.12 255.255.255.0

Switch2-Layer3-ETHERCHANNEL(config-if)# end

Switch2-Layer3-ETHERCHANNEL# configure terminal

Switch2-Layer3-ETHERCHANNEL(config)# interface range fastethernet0/0 -2

Switch2-Layer3-ETHERCHANNEL(config-if-range)# no switchport

Switch2-Layer3-ETHERCHANNEL(config-if-range)# no ip address

Switch2-Layer3-ETHERCHANNEL(config-if-range)# channel-group 1 mode auto

Switch2-Layer3-ETHERCHANNEL(config-if-range)# exit

This is all that we have to do on both switches. Please note that we have to execute the command of "no switchport" on Switch1 and Switch2 to transit from Layer2 EtherChannel to Layer3 mode. To verify the EtherChannel, run the command "show etherchannel". It will show you the port-channel information and is important from the troubleshooting point of view if you mess up the configurations. Oh! We forgot the most important thing. No this is not what you are thinking trust me. The most important thing is to "Save" the configurations  . Cheers.

Writing Services

Essay Writing
Service

Find out how the very best essay writing service can help you accomplish more and achieve higher marks today.

Assignment Writing Service

From complicated assignments to tricky tasks, our experts can tackle virtually any question thrown at them.

Dissertation Writing Service

A dissertation (also known as a thesis or research project) is probably the most important piece of work for any student! From full dissertations to individual chapters, we’re on hand to support you.

Coursework Writing Service

Our expert qualified writers can help you get your coursework right first time, every time.

Dissertation Proposal Service

The first step to completing a dissertation is to create a proposal that talks about what you wish to do. Our experts can design suitable methodologies - perfect to help you get started with a dissertation.

Report Writing
Service

Reports for any audience. Perfectly structured, professionally written, and tailored to suit your exact requirements.

Essay Skeleton Answer Service

If you’re just looking for some help to get started on an essay, our outline service provides you with a perfect essay plan.

Marking & Proofreading Service

Not sure if your work is hitting the mark? Struggling to get feedback from your lecturer? Our premium marking service was created just for you - get the feedback you deserve now.

Exam Revision
Service

Exams can be one of the most stressful experiences you’ll ever have! Revision is key, and we’re here to help. With custom created revision notes and exam answers, you’ll never feel underprepared again.