Quality Of Service For Voice Over Ip Computer Science Essay

Published:

This project report proposes strategies for improving quality of service of voice signal over Internet protocol network. Availability of voice and data on same network brought enormous financial benefits over using different network for voice and data. And as a result of VoIP benefit, number of users increased day by day which enhanced to find a solution for maintain better quality of voice. As Quality of voice depends on delay, jitter and packet loss of network, mechanism called cRTP, RSVP and queuing improve quality of service for voice. Quality of service is measured in term of MOS which is calculated by measuring delay, jitter, and packet loss of network. Using VQManager simulation tool, it is possible to measure QoS. High MOS implies better a QoS of VoIP Network.

Traditionally, voice network supporters inclined to observe Voice over IP technology among some disclaim and cynicism; in reality, believed that Voice over IP wouldn't be squeezed at all. This approach was primarily because of the fact to early growth, use and consumption of VoIP knowledge outcome in very poor quality voice calls which were extremely unreliable at that time. But because of quite a few factors with developments in VoIP have happened that have changed this poor situation for a voice network. These factors vary because of the some fundamental VoIP protocol, such as Session Initiation Protocol i.e. SIP and H.323 have improved strikingly, to other vital factor which has to guide VoIP networks by improving quality of service (QoS) mechanisms. [1]

Background

Lady using a tablet
Lady using a tablet

Professional

Essay Writers

Lady Using Tablet

Get your grade
or your money back

using our Essay Writing Service!

Essay Writing Service

In past, voice and Data could be transferred on different network which was more expensive than sending both on same network. VoIP is a technology which provides this benefit through using unused data bandwidth for voice and vice verse. VoIP is a technology which allows make calls using Internet connection instead of using traditional analog phone lines. In other ways, VoIP is a way to carry voice packets or phone calls over IP network. [2][3]

C:\Users\Bhavin\Desktop\project image\howipwork.jpg

Figure1. VoIP Network [4]

Advantage of VoIP

The most imported advantage of VoIP is cost savings .It is possible to make international calls, local calls, mobile calls and long distance calls using VoIP. Even so many VoIP service providers also provide unlimited data usage plans with unlimited voice usage plans. VoIP has lower basic rate too in term of the maintaining large network. Customers don't have to pay taxes and fees for VoIP service as they are paying for traditional telephone service. Another significant advantage of VoIP is available features. Obviously because digital technology has more features compare to analog traditional telephone service. Another advantage at cost is having a virtual phone number. VoIP service provider can assign any phone number in any area code, no need to be physically there in that area. VoIP also provides multi-party calls i.e. conference calls in cheaper way compare to traditional telephone service. VoIP also provides web based voice mail service which let customer listen their voicemail from Internet. In availability of Internet and computer, there is no need to buy VoIP phone as there are so many free soft-phones are available in market and customer can call from anywhere. [5][6]

VoIP Problems

In VoIP, Quality can be defined as how clear a voice can be listening and speak in continues form of sound without any disturbances or unwanted noise. A quality can depends on three major factors which are Loss of packets, Jitter, Delay. In VoIP, Service means how much facilities are given to consumers with minimum requirements in terms of communication. So service is just a communication facility. [7]

The major challenge for voice or other media connection typically in VoIP is how to provide guarantee that packet in such a network will not be dropped or delayed because of interference from other media or traffic. That's where Quality of Service comes into matter. Factors like Latency, Jitter and Packet Loss are needed to be considered for QoS. [8]

Figure2. Factors affect MOS

Latency is also defined as Delay for packet delivery. Latency is the time require for delivery of packet from source to destination. It is recommended to set round trip voice delay for callers of 150 ms or more. Jitter is known as measure of variation for latency caused b network when packet travel from source to destination. Jitter can be happen because of connectionless and packet switched type of networks as packets are travelling through different paths from source to destination. It is recommended to keep Jitter down to less than 100 ms using buffers to minimize jitter effect. Packet loss can create some problem for IP network. [9]

What is QOS and Why QOS

Lady using a tablet
Lady using a tablet

Comprehensive

Writing Services

Lady Using Tablet

Plagiarism-free
Always on Time

Marked to Standard

Order Now

Quality of service is defined as ability of a network which provides assurance at different level of service in forms of traffic. QoS provides has an ability to make high priority for voice traffic than other type of traffic. Best effort, Integrated Service and Differentiated Service are three levels of QoS. Best effort service make all possible attempt for delivery of packet from source to destination without dropping it, but there is no guarantee that packet will reach at destination. Integrated service works by negotiating network parameter and reserve some network resources for an application as soon as it begins transmission. Differentiated service provides queuing mechanism and classification to support certain application with a priority. So QoS can be implemented so many ways out of that this project will show three major mechanisms which are cRTP, RSVP and Queuing. This project will also provide advantages and disadvantages, purpose, configuration and of course basic operation for each individual technique. This project focuses on Cisco routers for implementation of QoS. [1]

QOS Mechanism

Figure3. QOS Mechanisms

RTP Header Compression

Introduction:

One of the solutions required to several VoIP operations is the economically eye-catching bandwidth reductions they bring. For instance, a standard Time Division Multiplexing voice call needs a flat allowance of 64 kbps part of a bandwidth, while a equivalent feature VoIP call can be trim downed to roughly 12 kbps. There are couples of compression are done on audio packets to accomplish such necessary bandwidth reductions: [10]

Header compression, in the course of features name as RTP header compression (known as cRTP)

Payload compression, using codec for example G.729

Background:

Header-compression schemes are expressed using numerous standards. The primary header-compression idea was thought by Van Jacobson for compressing headers of TCP/IP on network which has slow-speed links. Later on this method has been improved and accessible by the IPHC i.e. IP header compression designs, having Real Time Protocol compression addition considered to deal with any IP packet. Recent supplement to the header-compression assortment is robust header compression named as ROHC, a scheme proposed for unpredictable, high-latency links, where bandwidth is so much limited and most of the links are having a tendency to error (Compressed RTP in excess of satellite links is works on the ROHC).

The various Internet Engineering Task Force- Request for Comments (IETF-RFCs) concerning to header-compression techniques are

What is RTP

Real-Time Transport Protocol (RTP) is described in RFC1889. On IP network, RTP is used to handle voice compression designed for IP packets. RTP handle the audio path as well as video transfer for VoIP. RTP provides mechanism which helps in sequencing by identifying dropped packets using timestamp and other control mechanism. Basically RTP was designed for supporting multicast stream. VoIP packets are created of speech codec samples or speech codec frames which are encapsulated in IP/UDP/RTP headers with a size of 40 bytes. When the size of header of 40 bytes is compared with a size of VoIP payload which is of 20 bytes, it is large overhead and considered as a waste of bandwidth when voice packets pass through over low speed link. This is the reason why cRTP was created.

Figure4. IP/UDP/RTP Header [11]

What is cRTP and why require

Compressed Real-time Transport Protocol (cRTP) which is defined in RFC2508 offers a system by which the header overhead can reduce for RTP traffic by eradicating unneeded information among packets. For an example, imagine a data stream having a size of 1000 packets, and the first 999 have similar headers of the transmission. Is it valuable to use bandwidth by to send same information 999 times through router? Of course router wouldn't do it. So using this approach, cRTP eliminates that header information which is not requiring sending every time and utilizing bandwidth in correct manner.

bwidth_consume.gif Figure5. RTP Header Compression [13]

The potential to assistance compressed RTP to increase bandwidth savings for audio streams on slow links is for vital significance to private as well as public VoIP systems. As a result, cRTP is a crucial QoS mechanism in joined converged networks with considering even slow-speed links. Without absence of cRTP, VoIP service becomes inconvenient on links having a slower speed. Still with cRTP technique, network design should be considered such a way that at least voice quality is acceptable and maintained appropriately.

Lady using a tablet
Lady using a tablet

This Essay is

a Student's Work

Lady Using Tablet

This essay has been submitted by a student. This is not an example of the work written by our professional essay writers.

Examples of our work

cRTP provides following design implications for QoS network:

It transforms the header of packet and for that reason, should be decompressed ahead of routing which can take place. This assembles compressed RTP protocol, with occurring decompression and recompression.

It maintains the bandwidth which is required for a voice call and, that's way, changes provisioning, CAC (call admission control) policies and queuing mechanism, policing, and shaping.

There are compression and decompression algorithms which need CPU thorough. To perform cRTP mechanism on router, make sure that platform must have enough CPU power which performs data transfer as well as performs maximum calls.

The employment of cRTP is reliant on the lie behind Layer 2 protocol.

CRTP Operation

For the period of cRTP stream, a session context is created and defined and for every context of that session. Created session state then communicated between compressor and decompressor. As soon as context state is confirmed, cRTP packets can be sent.

The context state is a combination of the full IP/UDP/RTP headers, a generation number, sequence number, first order differential values, and a delta encoding table. The header part of context session is arranged by headers of full or uncompressed packet. [15]

The main requirement for decompression to be successful is synchronization of context state at compressor and decompressor. If this synchronization would not happen, compressed header is not able to be stored at decompressor and context state is sent back which indicate the context is corrupted. For continuation compression, a new copy of context must be shared.

Basic Idea for Compression Algorithm

The more than half bytes of TCP/IP header always remain constant for a connection. So before sending the compressed TCP headers, these fields may be removed from uncompressed header. Using the changing field, the remaining compressed headers derived from the differential coding to decrease their size.

Major advantage for cRTP occurs from the fact that most of time although some fields vary in each packets, the difference between packets is a lot constant which mean the second-order difference between packets is nil. Using the first-order differences in session state and the uncompressed header, original header can be achieved by adding uncompressed header with first -order differences.

CRTP should maintain multiple session contexts state. A session context can be described as the mixture of the IP address of source and destination, the UDP source ports and destination ports, and of course the RTP synchronization source identifier (SSRC) field as well. A small integer named CID or session context identifier, carried by compressed packet is an interpreter for packet regarding session. At the other side, decompressor stores session context on its index table. [11]

Header Compression for RTP Data Packets

IPv4 header includes fields such as total payload length, packet identification, and check-sum for header. Those fields are changed usually. The total payload length of header is obsolete with the length updated through the link layer. Because of compression scheme rely upon the link layer, link layer offers error detection for header checksum which can also eliminated for compression scheme. The remaining changing field called packet identification is transmitted to make sure that there is lossless compression and it is incremented using small for every packet. For IPv6 header, there are no fields such as packet identification or checksum, the only field which will change is payload length. [11 ]

UDP header has a field called the length, which is redundant with IP header's field called total length denoted by the link layer. The check-sum field in UDP header will be a constant if there will no need for checksum decided by source or else, the checksum should have been transmitted without compression to maintain lossless compression.

In the RTP header, the Synchronization Source Identifier (SSRC) is constant field for a particular context as it recognizes the specific context. The other fields such as timestamp and sequence number in RTP header will be change between packets. The sequence number will be incremented for every packet by compressor when any packets will not be misplaced or disordered. In case of constant duration for audio packets, timestamp is going to be increase with sample periods expressed in every packet. For video packets, first packet of each frame is making change on timestamp, but then remaining packets in that frame enhanced timestamp to stay constant. Generation Rate for video frames is constant and also variation in timestamp is constant between frames. [11]

Protocol

The compression protocol has to maintain a pool of mutual information between compressor and decompressor and MAY be negotiated among compressor and decompressor. The size for one context is recognized using an 8- or 16-bit identifier, so the maximum number of context can be 65536. Each context contains shared information which has following points:

Full Header or uncompressed packet format

Full header packet format is same as original packet. The only difference between these two formats is it needs to carry 4 bit sequence number as well as context identifier (CID). As this mechanism is used for reduce the packet size, these fields are inserted into length field of IP packet header and length field of UDP packet header. To work this out, there are two 16 bit length fields are required, which are taken from IP header and UDP header respectively. As shown in below diagram, depending on selection of the size of the Context identifier i.e. either 8 bit or 16 bit, the position of sequence number and context identifier are varies. For 8 bit context ID as shown in figure, first length field which has context identifier is inserted into IP header field and second length field which has sequence number is inserted into UDP header. While 16 bit CID, sequence number is inserted into IP header and Context identifier is inserted into UDP header. [11]

[12]

The length of CID is indicated by first bit in first length field. Because this is a case of compression scheme, 4 bit sequence number will be always there in length field and it is indicated by second bit of first length field using 1 bit. The generation field in length field is required for IPv6 in response to COMPRESSED_NON_TCP packets and is set to zero if IPv4, generation value to zero and this generation number is stored in context. When a packet received, the generation number is compared with the value which is stored in the context. The IP/UDP/RTP header information with sequence number will store if and only if generation match. [11]

CRTP packet format

If the second order difference between RTP headers of packets is zero, only work decompressor has to for constructing a packet is need to add uncompressed RTP header of previous packet with stored first order differences. But if the second order difference between RTP headers of packets is not zero then a new first order difference need to be update based on those packet fields and later on that first order difference will be stored into the context of decompressor.

Flow Graph for cRTP Header Compression

Flow Graph for cRTP Header Decompression

Configure cRTP

Queuing Mechanism

Introduction

It is very important to grasp the fundamentals of queuing mechanism. Queue nothing but it is a holding area on router. So it is a store or holds the packets in router until the resources are available. As soon as the resources are there, queue forwards packets to egress port which mean no congestion is there on router. So the purpose of queuing mechanism is to provide accommodation to bursts if the arriving packets are faster than the departure packets because of the either succeeding two reasons:

Like an example where a one interface of router is connected with LAN interface which has fast Ethernet speed while the other interface of the same router is connected to WAN with T1 circuit. So chunks of the packets coming to Ethernet interface is much faster than the chunks coming out to T1 interface of WAN network. That's why in this case if the queue is there on router, it can place the packets mean traffic to buffers which can hold it. Because of this holding area, WAN circuit can use this traffic at its own speed without changing its pace. This kind of approach is normal and essential to handle traffic for incoming interface and outgoing interface of network. [17]

Structure

Queuing is divided into two parts:

Software Queue

Hardware Queue

Figure6. Structure of Queuing mechanism

Hardware Queue is essential to transmit packets in order and it happen using First In First Out (FIFO) strategy. This Hardware queue is also known as transmitting queue. The Software queue is different than Hardware queue. Classification and schedules of packets is happen at software queue and packets are forwarded to hardware queue. Software queue is to be chosen depend on requirements of QoS.

The operation of software queuing can be perfected for a particular period of time when there is no sign for congestion in network and at this moment software queuing system need to be bypassed whenever software queue detect no packet in its queue. But at this point it needs to be take care that there is a space for packets in hardware queue. That's the reason why software queue is used when there are packets waiting for hardware queue. [18]

Figure7. Basic Idea of Queuing

Queuing Component

Queuing mechanism is divided into three components.

Classification

Insertion

Scheduling

Most of the mechanism of queuing is including this approach.

A router has to decide whether a coming packet need to be place in queue or need to be drop, after a classification of a packet. When the tail-drop queue for corresponding packet class is empty, a packet is inserted in a queue. But most of the queuing mechanism is dropping a packet since a queue is full. Mechanism like Weighted Fair Queuing uses effective approach for dropping scheme. Classification is done either by manually or automatically depending mechanisms since some of them has this feature.

Allow packet is inserted into FIFO queue according to defined a class for that particular packet. The FIFO queues are working on tail-drop scheme.

The most vital part of queuing mechanism is scheduling policy since it influences the order of packets which is forwarded to router.

At the end a packet is forwarded to common hardware queue, once it is taken out from class queue. [18]

The following figure explains these three components of queuing mechanism.

Figure8. Queuing function with basic components

There are several available queuing strategies which are helpful to VoIP network

This project is based on Priority Queuing mechanism.

Priority Queuing

The first mechanism who introduced classification of packets is the Priority Queuing who allows priority for packets into multiple classes. The priority queuing can classify incoming packets into any of the following four queues:

High queue

Medium queue

Normal queue (the default queue)

Low queue [18]

Figure9. Functional diagram of Priority queuing mechanism [18]

In this mechanism the packets coming in High queue is forwarded first to hardware queue. Once a high priority queue is empty, the next chance is given to medium priority queue in same manner and then normal queue. So if there is no packet in all above three priority queue, the low priority queue has given chance. Remember each queue is FIFO queue. So packets can be dropped easily if queue is full with packets.

Priority queuing categorizes IP packets using the following ways: [18]

Direct Matching on the source interface.

Standard or Extended IP Access. Extended IP access lists supports matching on the following parameters:

Priority Queuing is essentially a set of four First in First out Queues. So the problems which are occurring for FIFO type of queuing are occur in each this queue. Same tail-drop scheme which is occurring in FIFO occurs in each queue of priority queues. Configuration of each queue is such a like that it can hold maximum number of packets.

Priority Queuing Scheduling

Figure10. Priority Queuing Scheduling [18]

As shown in above figure, Priority queuing always gives a maximum priority to HIGH queue like a strict priority. As far as there is a packet in high queue, it has to serve first. No other queue will be requested to serve until the high queue will be empty. As soon as high priority queue will become empty, next packet will be serving from medium priority queue. So that's mean lower priority queue has to wait until normal queue is empty, it is called starvation for lower priority queue.

Priority Queuing Benefits and Drawbacks

Priority Queuing Configuration

Queue classified based on layer-3 protocol

Queuing classification based on incoming interface

Queuing classification based on maximum queue size of each individual queue

Assign queuing priority to an interface

Monitoring priority queuing

Router# show interface interface

Display information and statistics for queuing on defined interface.

Router# show queuing priority

Display queuing parameter

Resource Reservation Protocol (RSVP)

Introduction:

Resource Reservation Protocol, used to obtain Quality of Service in Voice over IP. RSVP basically reserves path for the packets between two entities. This type of reservation makes routing for the packets easy and fast. Because of the reservation routers do not need to go through whole routing table to route every single packets. During packet routing every single receiving Hop/ entities sends Reserve message to sender hop, which can establish the path for the reverse coming packet. This mechanism decreases latency for the packets. This kind of approach is really suitable for the Real time applications like live video, Voice calls and other live or real time applications.

RSVP is not Routing protocol, it is Transport level protocol. It coordinates with routing protocol. Packets containing RSVP information carries destination IP address as next RSVP capable router or receiver. This makes job easy and fast for the routing protocol. Result of this capability reduces latency time. In congest network RSVP works well with routing protocol.

RSVP supports Three Traffic Types.

Best-Effort

Rate Sensitive

Delay Sensitive

RSVP message type:

PATH

RESV

PATH Tear

RESV Tear

PATHErr

RESVErr

RESVConfirm

Usually sender sends PATH message, encapsulated in packets. PATH message includes previous and next hop address for the stream. Whenever PATH message received by any of the RSVP-enabled router than it is processed by RSVP daemon and RSVP responds by RESV address to reserve reverse path for the flow. PATH and RSVP messages are independent to each other, even though they follow the same path and pattern.

Figure11. RSVP request and RSVP path messages [19]

PATH

Each sender transmits these messages along the routers using routing protocol. Main objective of PATH message is to enable the router to learn next hop and previous hop for that sender. PATH messages are also used to refresh the state of PATH, periodically. This interval is known as refresh time. There is one equation which calculates the Refresh Time, Where keep-multiplier is specified number passed in PATH messages.

{(Keep-multiplier + 0.5) X 1.5 X refresh-time}

PATH Tear

This message follows same path which is followed by PATH message. This message removes or clears all reservation made by PATH message. It also deals with removal of dependency states in the router for entire path.

This message is not necessary but it helps improve performance of network, because it removes all unnecessary path reservation.

RESV

This message is sent by receiver, towards sender. Main focus of this message is to maintain reservation of the path for the upstream traffic.

RESV Tear

ResvTear messages remove reservation throughout path. These messages follows upstream path toward senders. ResvTear messages are the contrary of RESV messages. ResvTear messages typically are initiated by a receiver application or by a router when its reservation state times out.

This message is not necessary but it helps improve performance of network, because it releases network resources quickly.

PATHErr

Any PATH request fails, results in to error and the type of this message is usually unicast message.

RESVErr

Any RESV request fails, results in to error and the type of this message is usually unicast message.

How RSVP Works?

RSVP is soft-state protocol, which directly imposes importance of refresh process. If state of soft-state protocol not being refreshed periodically than it may expires. In reality the state of RSVP is cached n each hop. In the state of RSVP routing protocol also affects, if the routing protocol alters the path than reservation process is initiated once again.

Figure12. RSVP functioning [20]

Periodically RSVP does refresh process periodically, that leads to sender refreshes PATH messages and receiver refreshes RESV messages. By establishing link between sender and receiver RSVP provides quality of Service.

Dogma is tested by the RSVP-aware routers and switches. Devices might reject resource requests based on the results of these policy checks. If the registration is excluded due to lack of resources, the requested application is immediately informed that the network cannot currently support that amount requested service level. QoS- attentive applications, such as those controlling multicast transmissions, usually begin sending directly on a best-effort basis, which is then upgraded to QoS when the reservation is accepted.

RSVP Tunneling:

Over the internet we do not have control over all the routers or hops which comes in to the way of any RAVP communication. That's where this process fall in apart. This problem is solved by RSVP tunneling. Basically, RSVP tunneling remembers the IP address of routers/ any hop which have RSVP configured on it and any packet under RSVP communication takes and keeps destination IP address as next RSVP enabled router.

Figure13. RSVP tunneling [21]

RSVP is used by sender and receivers or hosts and Routers/ hops to request certain level of QoS from the network.

To follow that RSVP upholds state of all the hops to provide demanded service.

Implementation of RSVP

There are three basic steps to implement RSVP on the router. They are reserving bandwidth for the operation, simulate RESV command and simulate PATH command given by Senders and receivers.

ip rsvp bandwidth [interface-kbps] [single-flow-kbps]

Interface eth0

#ip address 10.10.1.1 255.255.255.0

#ip rsvp bandwidth 8000 1500

ip rsvp neighbors access-list-number

Interface eth0

#ip address 10.10.1.1 255.255.255.0

#ip rsvp neighbor 10

#access-list 10 deny host 10.10.4.1

#access-list 10 permit any

ip rsvp reservation session-ip-address sender-ip-address [tcp | udp | ip-protocol]session-dport sender-sport next-hop-ip address nexthop-interface {ff | se | wf} {rate | load} [bandwidth] [burst-size]

Session-ip-address: (Unicast) ip address of receiver | (Multicast) IP address of multicast session.

Sender-ip-address: (Unicast) IP address of Sender | (Multicast) IP address of sender

Tcp | udp | protocol : any IP protocol from 0 to 255

Session-dport / sport: Session destination port and Source Port.

Next-hop-ip-address: receiver ip address or hostname

FF | Se | Wf: (Fixed Filter) Single Reservation, (Shared Expicit) Shared Reservation - limited Scope, (Wild Card) Shared Reservation - unlimited Scope.

Rate | load: guaranteed bit rate | controlled Load Service

Bandwidth: Average bit rate to reserve.

Burst-size: maximum Kb data in queue.

ip rsvp sender session-ip-address sender-ip-address [tcp | udp | ip-protocol] session-dport sender-sport previous-hop-ip-address previous-hop-interface [bandwidth] [burst-size]

Details of parameter used in this command are explained above.

Advantages of RSVP

There are many factors makes RSVP so important solution for the Voice over IP service, video over IP service on broader sense for any delay and bit rate sensitive service. For those service QoS is so important. Followings are advantages of RSVP.

Complex Topology: RSVP has capability of dealing with large and comlex network

Network Awareness: RSVP known as network control protocol, it also displays network awareness using different messages.

Video Conferencing: This service needs constant flow of traffic without latency. RSVP helps keep designated bandwidth assigned to the service which also results in latency reduction.

Capabilities of RSVP

Dealing with different kind of services, RSVP has to be capable of handling and enchasing different services and their communication over the internet. Following are capabilities of RSVP.

Signaling protocols SIP, SCCP, MGCP and H.323 are supported by RSVP

It supports bandwidth reservation.

It provides application ID support.

It works by enforcing policies, so that we can enable or disable RSVP service

It retains reservation even when the conversation or current session has been put on hold.

Implementation

This section of the project took most of the time to design the network and then selecting suitable hardware which mostly include Switches and Routers.

Router selection Criteria:

Must support SIP

Must support cRTP, RSVP configurable

Must support all queuing mechanisms.

Switch Selection Criteria:

Must support multiple layers (Layer 2 - 3) of network.

Must be managed switch

Must support Prioritizing of VoIP packets.

Should be gigabit Ethernet switch

After analyzing multiple routers we found that Cisco Router 7200 is best router for hosting VoIP system. We also examined several layer 3 and we came to conclusion that Cisco catalyst 3550G switch is suitable for the VoIP system. We have also examined several software phones and Hardware phones. There are several hardware phones popular in the industrial market they includes cisco phones and Polycom Phones. To make testing we have used Polycom 501.

Features of Cisco 7200 Router:

Quality of Service:

(CBWRED) Class-Based Weighted Random Early Detection

(LLQ) Low-Latency Queuing

(GTS) Generic Traffic Shaping

(FRTS) Frame Relay Traffic Shaping

(CBWFQ) Class-Based Weighted Fair Queuing

(MQC) Modular QoS command-line interface

Marking

(CAR) Committed Access Rate

Other Services:

FRF11/12

MLFR

cRTP

MLPPP

LFI

Features Cisco 3550 Switch:

VoIP capabilities:

(PIM) Protocol-Independent Multicast

(DVMRP) Distance Vector Multicast Routing Protocol tunneling

IGMP filtering provides control of the set of multicast groups to which a user on a switch port can belong.

Voice VLAN

(CGMP) Cisco Group Management Protocol

IGMP snooping allows limits bandwidth-intensive.

(WCCP) Web Cache Communication Protocol enables integration of cache engines into the network infrastructure.

Polycom 501 Phone:

This model of Polycom, 501 supports SIP and MGCP protocols. By default SIP is used on this phone but we can also configure it to use MGCP.

Test Topology:

After taking many points taking in to account, we designed following topology which is most

Common topology in field of Networking for hosted and on premises VoIP service.

Topology Explanation:

Starting with server side, we first configure Cisco 7200 router with OSPF routing protocol. After configuring routing protocol we made test if we can ping outside or not. First getting ping gone through, we connected switch Cisco 3550. We provided IP address to the switch using management Vlan number 10. We also configured priority for VoIP packets forwarded from each port. So following flow graph explain whole graph for packet flow.

Process of packet travel is very formal, after configuring router and switch over voice Vlan. We attached Asterisk server to the switch. Asterisk server is configured for few phone numbers we used for the testing. Other than that, we have configured few basic features to support like call forward and call block. Using that configuration file, "SIP.conf" and "asterisk.conf" we supported four phones to the server.

So, after configuration of server we attached it to switch. Through which we connected to router. Now, we attached core switch to the router Cisco 7200. Cisco 3550 switch can also host priority configuration for the VoIP. After we plug in our phones to switch they get on to internet. Phone directly registers themselves to Asterisk server. After registration process, phones are ready to host any calls or will also able to call out.

We plugged in our tool to measure MOS, VQManager to the switch. We made VQManager receive all the traffic from only one switch port. We used port monitoring and port Spanning system.

Operational Diagram Of Network:

VQManager

Measure Mean Opinion Score of the network is very critical point for voice over IP service. To measure Mean Opinion score mainly known as MOS. We examined several tools for measure real time MOS score for several calls and we found VQManager is best in the market. VQManager monitors voice Vlan and gets all the traffic going through it, it counts the delay in packet, Jitter that voice over IP stream is getting, and also the packet loss. Following is the screen shot of tool VQManager.

Specifications and Features:

It can handle 500 real-time calls

It provides configurable QoS edges

Real-time calls tracking

It also provides endpoint specific QoS digests

SIP process tracking

Resource grouping

Raw packet statistics display

It also provides email alert

Configuring VQManager with Cisco Switch 3550:

To start with, VQManager after we login user have to specify the interface on which VQManager will be listening the call/ VoIP packets and it will start measuring Delay, jitter, packet loss and Mean Opinion Score. Interface information becomes critical in this configuration on the part of VQManager; wrong interface indication will be providing us wrong data.

Testing Results:

We took two scenarios for testing; one is without QoS techniques implementation and after that with implementation of QoS techniques. Following is screen shot of testing we did before QoS techniques implementation.

Following Table shows detail of readings we got in the test.

Factors

Minimum

Maximum

Average

Delay

3

1097

78

Jitter

2

4

2

Loss

0

1

0

MOS

3.3

4.4

4.2

R Factor

64

92

89

Table Number 1: Test results before QoS techniques implementation.

Test after QoS techniques implementation:

After testing without QoS techniques implementation we started implementing cRTP, priority queuing and Resource Reservation Protocol. There are several ways we can configure selection of specific methodology is very important which methodology we select for the network topology. Selection of the specific methodology should be according to the type of the network, Configuration of the network, Bandwidth of the internet connection, traffic of the network on pic ours of the usage. Performance of the network depends on selection of the specific methodology So if we select different methodology than it is possible to get different results than we got in the following test screen shot.

Table # 2: Test Results after configuration of QoS techniques

Factors

Minimum

Maximum

Average

Delay

10

101

39

Jitter

3

6

4

Loss

0

4

2

MOS

4.3

4.4

4.3

R Factor

90

93

91

Graph # 2: Comparison of MOS with and without QoS techniques implementation

From the above comparison it is clear that with QoS techniques configuration traffic in the network gets more stable. Deviation of minimum MOS in the network is more stable in with QoS techniques configuration. Without QoS configured network also faced more delay also average and maximum.

Router Configuration:

Cisco-7200-Router#sh run

Building configuration...

Current configuration : 2297 bytes

!

! Last configuration change at 18:17:35 UTC Wed May 4 2011

!

upgrade fpd auto

version 15.0

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Cisco-7200-Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

!

!

ip source-route

ip cef

!

!

!

!

no ip domain lookup

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

!

!

!

!

!

redundancy

!

!

!

!

!

!

!

!

!

interface Ethernet0/0

no ip address

shutdown

duplex auto

!

!

interface GigabitEthernet0/0

ip address 10.0.0.1 255.0.0.0

ip access-group 20 out

ip nat inside

ip virtual-reassembly

duplex full

speed 1000

media-type gbic

negotiation auto

!

ip rsvp bandwidth 7500 1000

!

interface GigabitEthernet0/0.1

!

interface GigabitEthernet1/0

no ip address

shutdown

negotiation auto

!

!

interface GigabitEthernet2/0

no ip address

shutdown

negotiation auto

!

!

interface Serial3/0

ip address 63.121.57.89 255.255.255.224

ip nat outside

ip virtual-reassembly

encapsulation frame-relay

fair-queue 64 256 37

serial restart-delay 0

frame-relay interface-dlci 400

!

ip rsvp bandwidth 7500 1000

!

interface Serial3/1

no ip address

shutdown

serial restart-delay 0

!

!

interface Serial3/2

no ip address

shutdown

serial restart-delay 0

!

!

interface Serial3/3

no ip address

shutdown

serial restart-delay 0

!

!

interface FastEthernet4/0

no ip address

shutdown

duplex half

!

!

!

router ospf 10

log-adjacency-changes

network 10.0.0.0 0.0.0.255 area 0

network 63.121.57.64 0.0.0.31 area 0

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

ip nat pool SJSU-EE 63.121.57.64 63.121.57.94 prefix-length 27

ip nat inside source list 7 pool SJSU-EE

ip rsvp sender 63.121.57.90 63.121.57.89 UDP 555 666 63.121.57.89 Serial3/0 7500 1000

ip rsvp reservation 63.121.57.90 63.121.57.89 UDP 555 666 63.121.57.89 Serial3/0 SE RATE 7500 1000

!

access-list 7 permit 10.0.0.0 0.255.255.255

access-list 10 permit 10.0.0.0 0.0.0.255

access-list 20 permit 10.1.0.0 0.0.0.255

priority-list 1 protocol ip high list 10

priority-list 2 protocol http medium

!

!

!

!

!

!

control-plane

!

!

!

!

!

!

gatekeeper

shutdown

!

!

line con 0

exec-timeout 0 0

logging synchronous

stopbits 1

line aux 0

stopbits 1

line vty 0 4

login

!

end