Ip Tunneling Advantages Applications Computer Science Essay

Published:

In this paper the technique of tunneling, its advantages and its implementation is discussed in detail. All of the concepts are discussed step by step. So by the end of this paper, we will be able to know that what tunneling is, what is the technology that is used to implement this technique and what are the advantages of using this technique.

In this world of technology, a lot of research has been done in the field of telecommunications and networking in recent years. More & more sophisticated protocols have been developed for quick and efficient transfer of data over the network.

But there may be some portions in a network which may not have been upgraded or using the latest protocols. This fact can be explained by the example that if the communication is to be made between the two stations using the latest protocol and packet must pass through a region having an older version of protocol. There arises a problem in this situation. The packet having the address of latest protocol must have an older protocol address while passing through the region having older version of protocol. To tackle this problem, a strategy named "tunneling" is used.

Lady using a tablet
Lady using a tablet

Professional

Essay Writers

Lady Using Tablet

Get your grade
or your money back

using our Essay Writing Service!

Essay Writing Service

In tunneling, the multicast packet is encapsulated in a unicast packet and sent through the network, where it emerges from the other side as a multicast packet [1].

This situation is shown in the figure 1.1. Here we can see that the data is being sent from a station where a new protocol is being used, and the same is used at the receiver side. But it has to pass through a region where an older version of protocol is used. So a virtual tunnel has been made by attaching the address or header of the old protocol while passing through this region. So this figure clearly demonstrates the concept of tunneling.

An understandable example of the above discusses phenomenon is that, nowadays a new version of protocol IPv6 is being used in some network areas. Now if the data has to be transmitted between two stations using IPv6 protocol, and data has to pass through a region of network where IPv4 is being used, then the concept of tunneling helps a lot to tackle this problem.

So the concept of tunneling is being applied using technology discussed as under.

2. Technology:

Every technique after a critical analysis, is implemented using some technology. Tunneling is implemented using a technology named 'Generic Routing Encapsulation(GRE)'. In this technology , Generic Routing Encapsulation (GRE) tunnel builds a path through the public internet while encapsulating traffic with new packet headers that ensures the deliver to a specified destination [2].

It is a general purpose protocol which reduces the size of complexity of encapsulation that is present in other encapsulation protocols. In this GRE, if a packet is needed to be delivered to from some source to some destination, then this packet is termed as payload packet.

This payload packet is first encapsulated in GRE packet. The standard GRE packet is shown in figure2.1 [3].

This GRE packet is than again encapsulated to other packet and then transmitted. When this packet is received at some remote destination, it is checked that whether it is a GRE packet or not. If the receiving system identifies it as a GRE packet, then the corresponding sequence number and checksum fields must be checked. After checking the respective addresses and other relative information, the receiver extracts the original information from the GRE header. This technology is gaining more reputation as the latest IP protocols (i.e. IPv6) have been developed and the data is to be transmitted through the regions of network which are still using the older IP protocol versions (i.e. IPv4).

3. Issue:

The main issue that is to be addressed in this research paper is that how the tunneling is applied to transfer a packet from source to destination in the presence of older versions of protocols in the route. Another issue is that how the packet can be delivered from source to destination privately over the public internet. The application of GRE technology can solve the crises.

Lady using a tablet
Lady using a tablet

Comprehensive

Writing Services

Lady Using Tablet

Plagiarism-free
Always on Time

Marked to Standard

Order Now

As described earlier that how the packet is transmitted from one station to another using the concept of tunneling, but here it will be described in detail. To understand the operation of generic routing encapsulation, we need to understand the GRE header[4] which has been shown in figure 3.1.

C(bit 0): The first bit C refers to the checksum bit, if it is one, it means that some valid information is present in it.

R(bit 1): This bit refers to the 'routing present' bit. If this bit is one, it means that some kind of routing information is present in the header. It is mostly 1 because this header is used for routing only.

K(bit 2): This bit refers to the 'key present' bit. 1 in this bit shows that key is present in this header.

S(bit 3): This bit indicates the sequence number field present in the GRE header.

s(bit 4): This bit refers to the 'strict source routing'[5]. This bit is only set to 1, if all the information about the strict source route is present in the header.

Recur(bit 5-7): This 3-bit field refers to the number of more encapsulations permitted in the GRE header. By default, it is set to 0.

rsv(bit 8-12): This 5-bit field must be always set to 0. It is ignored on reception.

Ver(bit 13-15): This field describes the version of the GRE header that is being used.

Protocol(bit 16-32): This field contains the type of the payload packet protocol. A number of protocols are supported by GRE, the table 3.1 contains all the supported protocols[4]. In front of each protocol type, the number is mentioned which is entered in the Protocol field of the GRE header.

All the next fields which also have been mentioned above are the optional fields. However to understand our problem well, we will describe a little of each field.

Checksum(bit 33-48): This field contains the IP checksum of GRE header and payload packet. As described above that this field is only applicable when R or C bit is 1.

Offset(bit 49-64): This field contains the offset in octets from the start of the routing field to the first field of active source route entry.

Key(bit 65-96): This field contains a four octet number which is used by the receiver for the authentication of the source of the delivered packet. This number is inserted by the encapsulator while encapsulating the payload packet.

Sequence Number(bit 97-128):

This field is used to put the received packets in order. This field contains an unsigned 32-bit number which is inserted in the header by the encapsulator.

Routing(bit 129-160): This field contains the source route entries and this field is only applicable if the R bit is set to 1.

After understanding the header of GRE, we are able to understand that how two routers can be configured for the GRE. The following commands on CLI configure the two routers for encapsulation [6].

GRE-1#

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password encryption

!

hostname GRE-1

interface tunnel0

ip unnumbered Serial1

tunnel source Serial1

tunnel destination 50.1.1.2

!

interface Ethernet0

ip address 10.1.1.2 255.255.255.0

!

!

interface Serial1

ip address 50.1.1.1 255.255.255.0

encapsulation ppp

!

ip classless

ip route 10.1.2.0 255.255.255.0 Tunnel0

!

line con 0

line aux 0

line vty 0 4

login

!

end

GRE-1#

GRE-2#

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password encryption

!

hostname GRE-2

ip subnet-zero

interface tunnel0

ip unnumbered Serial0

keepalive 5 4

tunnel source Serial0

tunnel destination 50.1.1.1

!

interface Ethernet0

ip address 10.1.2.1 255.255.255.0

encapsulation ppp

no fair-queue

clockrate 9600

!

ip classless

ip route 10.1.1.0 255.255.255.0 Tunnel0

no ip http server

!

!

Line con 0

transport input none

line aux 0

line vty 0 4

!

end

GRE-2#

So after configuring the routers by using the above written commands, the two routers will be able to transmit packets using GRE. So that's how the problem of transmitting data over net with privacy or through older protocol route is solved.

4. Advantages of GRE:

Lady using a tablet
Lady using a tablet

This Essay is

a Student's Work

Lady Using Tablet

This essay has been submitted by a student. This is not an example of the work written by our professional essay writers.

Examples of our work

This tunneling protocol offers a wide range of advantages over other security techniques, but some of the advantages are listed below.

1. As its name suggests, it provides multi-protocol network over single protocol.

2. It is the most applicable standard for tunneling after Connectionless Networking Service (CLNS) [7].

3. It can connect two disconnected sub-networks.

4. It allows Virtual Private Networks (VPNs) over the Wide Area networks (WANs).

5. It can transport data privately over public internet connection.

5. Disadvantages of GRE:

There are no significant disadvantage of this technology. The only disadvantage is the usage of four extra bytes between the payload and Connectionless Network Protocol (CLNP) [8].

6. Conclusion:

From all the above discussed material, we concluded that the transmission of the data privately over the network is possible using GRE. As its advantages in networking are far more than its disadvantages, so is seems to be the optimum solution for the purpose of tunneling. More and more standards are being proposed for the improvement of GRE. So there might be a boom of this technology in near future.